Jump to content

Archived

This topic is now archived and is closed to further replies.

Potential Stutter Fix - Steam Compatibility Mode

Recommended Posts

I just read about people fixing stuttering issues, (from G27 stutter thread on Steam): http://steamcommunity.com/app/310560/discussions/0/594820656467393699/

It seems Steam can get set stuck in Compatibility Mode, and it requires a registry edit to reset. If you're still seeing stuttering issues, please try this, (and also try unplugging any non-essential USB devices as a test).

WARNING: Only attempt this if you're comfortable editing the registry. And even then, make a backup of the affected folders before editing.

First, right click Steam, go to Properties/Compatibility, and make sure it's not set to run in Compatibility mode in there.
Then inspect the registry as follows:

From http://www.edugeek.net/forums/gaming/39417-fix-steam-thinks-its-running-compatibility-mode.html
To fix the issue:
  1. Hit start->run->regedit
  2. Go to key: HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
  3. Look for a entry with your path to steam.exe
  4. Delete that entry
  5. If you dont find it there try HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
When deleting the keys for Steam in the AppCompatFlags\Layers folders in the registry, look out for any DiRT Rally exe keys and delete those too.

WARNING: Only attempt this if you're comfortable editing the registry. And even then, make a backup of the affected folders before editing.

Seems a legit problem and fix, just Google:
steam compatibility mode stutter AppCompatFlags
and you can see it helping people in all sorts of games.



Hope it helps some people!

Share this post


Link to post
Share on other sites
Setting the drt.exe to be Run as Administrator cured the microstutters I was experiencing.  It was the only thing that worked as I don't use an R9, Steam was not in compatibility mode and I don't use a G27.

Share this post


Link to post
Share on other sites
Setting the drt.exe to be Run as Administrator cured the microstutters I was experiencing.  It was the only thing that worked as I don't use an R9, Steam was not in compatibility mode and I don't use a G27.
Thank you so much Hustler427, this fixed the microstutters for me as well... the only thing that worked!! I'm using a T300RS and Windows 10. 

Share this post


Link to post
Share on other sites

×